Article ID : 00021722 / Last Modified : 07/06/2016

Error: LAN adapter is required appears when trying to set up or connect to wireless connection.

Applicable Products and Categories of This Article

Follow these steps to check the Network environment if the error message LAN adapter is required appears when trying to connect to a Wi-Fi® connection.

NOTE: Because each of these steps represents a possible solution to this issue, try to connect to the Network after completing each step.

  1. Using another Internet device in the home, make sure that the Internet Network is active.
  2. Make sure that the router is set to 2.4GHz setting.

    NOTES:

    • The Internet video device supports 2.4GHz N-Band wireless support. In many cases you can use the Sony® UWABR100 USB LAN adapter to expand the coverage to allow the use of a 5GHz N-Band wireless router. Refer to the manual supplied with the Internet video device regarding the use of the Sony USB LAN adapter. Manuals are posted on your model support page.
    • Using a 5 GHz or 802.11a/n band router may exhibit issues on the Internet video device such as dropped connections, slow speed or limited Internet connectivity.
  3. Turn off or disable the wireless connection on other wireless Internet devices on the Network. If this step resolves the issue, check your router settings and specifications. There may be a limit to the amount of devices that can be used on the Network or another setting changed may be required.

NOTE: For additional information regarding how to verify or adjust the router settings, contact your router manufacturer.

If a connection cannot be established or the error continues to appear, follow these steps on the Internet video device itself:

  1. Reset the Internet video device.
  2. Make sure that the latest system software update has been installed. Downloads are posted on your model support page.
  3. Re-attempt to connect to the Network using an Auto or Manual connection.